More Dialog Boxes...
Export Gedcom File Dialog

Export Gedcom File Dialog
The Export Gedcom File dialog gives you considerable control over
exactly what gets exported into a GEDCOM
file. For most purposes, it should be all you need. But if you want even
more fine-grained control than it allows, you should do an initial
export using this dialog, then open the exported GEDCOM file within
Family Historian (click on
on the menu - under ) and use Family Historian to delete any extra
details that you do not wish to be there. This works because
Family Historian uses GEDCOM as its own 'native' file format. The Split
Tree Helper Tool is designed to help with deletions in
this kind of situation.
GEDCOM 7
The latest version of GEDCOM is version 7 and Family Historian supports this format for both import and export. However, GEDCOM 7 is not yet widely-used. For this reason, we only recommend that you select "GEDCOM 7" as the destination if you are creating a GEDCOM file that you plan to give to a program which you know supports it. If GEDCOM 7 is the selected destination, the "File Format" option and "Same Sex Relationships" option are both hidden. This is because they are not needed (and are not allowed) with GEDCOM 7, as it specifies both file format, and how same sex relationships are handled.
GEDCOM 5.5.1
If you choose any value as the Destination except 'GEDCOM 7', the resulting GEDCOM file will be in GEDCOM 5.5.1 format. If you are creating a GEDCOM file that you plan to give to a Family Historian 8 user, you are recommended to use 'Default' as the destination. 5.5.1 is the most widely supported version of GEDCOM, and therefore often the best option for export. Family Historian is 100% GEDCOM 5.5.1 compatible and complete in that it supports all standard 5.5.1 records and fields, and all values for those fields, for both import and export. A few options in the Export dialog allow you to create GEDCOM files which may not conform strictly to the GEDCOM 5.5.1 standard in particular ways. The reason these options are allowed is because they are useful and, perhaps surprisingly, may result in GEDCOM files which are more compatible with other genealogy programs than they would be if they were strictly conformant. For example, ANSI is not an approved standard format for GEDCOM files. But ANSI is still a widely-used format for GEDCOM files - at least in a Windows environment. If despite this, and for whatever reason, it is important to you that your exported GEDCOM file does strictly conform to the GEDCOM 5.5.1 standard, you should choose 'GEDCOM 5.5.1 (strict)' as the value for 'Destination' and use either 'Include in Strict Gedcom Format' or 'Exclude' for Same Sex Relationships. You should use 'UTF-8', 'Unicode', 'ANSEL' or 'ASCII' for File Format, and you should use any option other than 'Embed Media in Export File' for Media Records (embedding was permitted until 5.5 but dropped in 5.5.1). You may also wish to exclude Place records, Address records, Research Note records, and Source Template records, although you do not have to. This is because Place records, Address records, Research Note records and Source Template records are created using 'application extensions' to GEDCOM. Application extensions are valid GEDCOM, but unless other applications use the same application extensions, they may be ignored, or even treated as errors, by other programs that do not recognise them. Any destination which requires strict GEDCOM is unlikely to support Family Historian Place records, Address Records, Research Note records and Source Template records. Consequently, by default, if you choose 'GEDCOM 5.5.1 (strict)' as your destination, these records will be marked for exclusion.
See below for more details about these various options.
Fields
| Destination |
In general you are recommended to use 'Default' as your chosen location. By default, in all cases, 'Non-Generic Source-Handling' is set to 'Prioritize Compatibility'. You may wish to adjust this setting depending on your requirements. See 'Non-generic Source-handling' below. If you are planning to give the exported GEDCOM file to someone
who has Family Historian 7 you can use the 'Family Historian 7'
option. This will by default exclude Address records,
which are not supported in version 7. If you are planning to give the exported GEDCOM file to someone who has Family Historian 6, or any earlier version of Family Historian, choose 'Family Historian 6 or earlier'. This ensures that faces will display correctly when the GEDCOM file is opened or imported into a project. If you are planning to import the exported GEDCOM file into
Family Tree Maker, you can also choose 'Family Tree Maker'. If you wish the exported GEDCOM file to conform strictly to the GEDCOM 5.5.1 specification, choose 'GEDCOM 5.5.1 (strict)'. The 'GEDCOM 5.5.1 (standard)' option will generate a GEDCOM file that conforms very tightly to the Gedcom specification, but less rigorously than 'GEDCOM 5.5.1 (strict)'. Although strict GEDCOM conformance may seem desirable, it is rarely what you really want in practice. In fact, both 'GEDCOM 5.5.1 (strict)' and 'GEDCOM 5.5.1 (standard)' will result in GEDCOM files that are less compatible with most other genealogy programs than either 'Default' or 'Family Tree Maker'. For this reason, you are recommended to not use either 'GEDCOM 5.5.1 (strict)' or 'GEDCOM 5.5.1 (standard)' unless you have already tried the other options and they did not give satisfactory results. See 'GEDCOM 5.5.1' above. If you choose 'Family Tree Maker' as Destination, you will be warned when you click OK, if your chosen option for Same Sex Relationships is either 'Include in Symmetric Format' or 'Include in Strict Gedcom Format' as neither of these will be recognised by any version of Family Tree Maker. If you choose 'GEDCOM 5.5.1 (strict)' as Destination, you will be warned when you click OK, if your chosen options do not conform strictly to the GEDCOM spec. if you choose 'GEDCOM 7' as Destination, the GEDCOM file will be in GEDCOM 7 format. Be aware that this is not yet widely supported. Note: If you set the Destination to 'Family Historian 6 or earlier', the GEDCOM file will be saved with special Family Historian version number 6.5, the meaning of which is effectively "exported by version 7 or later, for version 6 or earlier". In fact there never was a version 6.5 of Family Historian. |
|---|---|
| File Format |
This field is hidden (not needed) if the Destination is 'GEDCOM 7'. When available it allows you to choose your preferred file format for the exported file. For a full list of descriptions of file formats, see Export Format Dialog. |
| Add All | Add all Individual records to the list of Individual records to
be included in the export. |
| Select | Opens a selection dialog, to allow selection of the Individual
records to be included in the export. |
| Records to Exclude | Choose record types you wish to exclude from the export. If you tick the option to exclude 'Place records', all place records will be excluded from the export. Excluding place records does not mean that no place information is exported. It means that any information stored about places within Place records (that is, media, notes, latitude and longitude) are not exported. Likewise if you tick the option to exclude 'Address records', all address records will be excluded from the export. Excluding address records does not mean that no address information is exported. It means that any information stored about addresses within Address records (that is, media, notes, latitude and longitude) are not exported. If you tick the option to exclude "One-member Family records", Family records which would be left with only one member (given the list of Individuals selected for export) will be excluded. Family records which would be left with no members are always excluded in any case. If you tick the option to exclude "Unconnected records", all records which, after the export, would not be linked, directly or indirectly, to any of the list of Individuals selected for export, will be excluded. |
| Facts & Notes | Facts (that is, events and attributes) can be flagged as
'Private', 'Tentative' or 'Rejected', in the Fact tab of the
Property Box. By default, any facts flagged in this way are
excluded from an export. If you wish them to be included in
the export, untick the appropriate box. Notes can appear in many contexts within Family Historian. Even if you have excluded Note records, there may be numerous notes within other records. In Family Historian you can mark notes, within a Notes field, as private, by enclosing the text within doubled square brackets. If the option 'Exclude [[private]] notes' is ticked, any notes marked in this way will be excluded from the export. To learn more see Private Notes. In Family Historian notes, you can use numerous word-processing features, such as italics, bold, strikethrough, font type, font size, font colour, bullets, tables, links, note citations, web links, paragraph formatting, indentation and more. Supporting these features requires embedding special formatting codes in notes. These formatting codes are not part of the GEDCOM spec, and other genealogy applications are unlikely to support all of them and may support none of them. For this reason, if you are exporting to an application other than Family Historian, you are normally recommended to remove all special word-processing features by ticking the option to "Convert notes to plain text". |
| Media Records |
There are 4 possible values. These are:
See the note Exporting Media below for more information about these options. |
| Non-generic Source-handling |
This option is greyed and not available if the option to exclude Source records is ticked. There are 3 subtypes of Source record in Family Historian. These are:
Generic Source records use standard GEDCOM fields. So exporting generic Source records (and source citations relating to them) is not a problem. However, GEDCOM currently has no built-in support for free form Source records or templated Source records. Also, Family Historian allows all source citations to be customized, at either the Source record level, or at the citation level, and GEDCOM currently has no built-in support for this either. So Family Historian offers a mechanism (called "prioritizing compatibility") to ensure that source citations, can be correctly transferred via GEDCOM, using standard GEDCOM fields, not just to another copy of Family Historian but also to other genealogy programs too - even if those other genealogy programs only support basic GEDCOM functionality, and do not support free form sources, templated sources, or customization of source citations. There are 6 possible choices with respect to non-generic source-handling:
If you take any option that includes prioritizing compatibility (that is, the 2nd, 5th and 6th), Family Historian will copy details of footnote citations, as they would appear in reports, to generic source and citation fields. This should ensure that any genealogy program which supports GEDCOM sources and citations, will have the full, correct citation details - even for sources that were originally free form, templated, or customized. For this reason, you are usually recommended to select an option which includes this feature. The functionality relating to prioritizing compatibility is not needed, and has no effect, if the GEDCOM is to be imported into a copy of Family Historian, version 8 or later. However, even here, it does no harm to enable it, which is why prioritizing compatibility is the default option. As well as, or instead of, prioritizing compatibility, Family Historian also offers the option to copy fields from templated Source records and citations, and/or customized source citation details, into a note, attached to the Source record or citation. Both Source records and citations can have multiple notes. Family Historian supports all such notes, but some other genealogy programs may only support one note per Source record or citation. For this reason, you can choose between copying the details into the first note associated with Source record or citation (by appending the details to the existing note, if there is one), or by copying the details into a separate (new) note. If your project does not contain any sources and citations based on source templates, or any customized source citations, this option is not applicable. |
| Same Sex Relationships |
This field is hidden (not needed) if the Destination is 'GEDCOM 7'. With other destinations, this option is available, but will have no effect if the Individuals you have selected for export do not include any two people who have a recorded same sex relationship. There are 4 possible values. These are:
If in doubt use unless you wish to exclude same sex relationships, in which case choose . For more information about all four options, see Exporting Same Sex Relationship Information. Tip: If you wish to check whether your current
file or project includes any same sex relationships, close the
Export Gedcom File dialog box and run the 'Same Sex
Relationships' query. To do this, click on the
menu, and then ,
and then .
If the 'Result Set' window is blank, your current file or
project does not contain any same sex relationships. |
| Override Copyright Text |
Each GEDCOM file contains a special record called a 'Header' which may optionally contain, amongst other things, a copyright message. Take this option if you wish to override the copyright message that is used in the current GEDCOM file. Tip: To view and edit the copyright message for the current GEDCOM file, close this dialog box, then click on the View menu, and then Special Records, and then Header record. |
| Override File Description |
As well as a copyright message, the 'Header' record in each GEDCOM file (see "Override Copyright Text" immediately above), may optionally contain, amongst other things, a file description. Take this option if you wish to override the file description that is used in the current GEDCOM file. Tip: To view and edit the file description for the current GEDCOM file, close this dialog box, then click on the View> menu, and then Special Records, and then Header record. |
Exporting Media
The recommended way of including media with your data, when exporting, is to export using a GEDZIP file. To do that, close the Export GEDCOM File dialog, and from the main 'File' menu, choose 'Import/Export' and then 'Export' and finally "GEDZIP File (GEDCOM and Media)". If, however, you wish to transfer data to a program that does not support GEDZIP files, this section describes the options available to you.
If you wish to export media with your GEDCOM file, the simplest option might appear to be to use 'Embed Media in Export File' (see the Media Records field). In this case, all media will be automatically embedded in the exported file. The disadvantage of this option is that depending on how much media, you have, the GEDCOM might end up being very large. Also, the latest version of the GEDCOM standard (5.5.1) no longer supports this feature. It was supported until 5.5 and Family Historian still permits it for this reason. Some genealogy applications that support GEDCOM 5.5, might be able to load embedded media. But in practice this is unlikely. Even genealogy applications that support 5.5, rarely support this particular feature. So what are the alternatives?
If you use the 'Use Existing File Paths for External File Links' option, the likelihood is that when you next view your GEDCOM file, some or all of the media (e.g. pictures) may have disappeared. The reason for that is this: Family Historian allows you to store links to external media files on your hard disk. If the media files are kept in your project folder (which is recommended), Family Historian will store the links as relative file links - meaning that it stores the location of the media files relative to the GEDCOM file itself. The big advantage of this is that if you copy or move an entire project folder from one place to another (or from one computer to another even), the links will all still work correctly, regardless of where the project folder is put. However, for the same reason, if you simply create a copy of your GEDCOM file, without also copying the media files that it has links to, to their equivalent location relative to the copied file, these links will no longer work when you open the copied file. To give an example: if an exported GEDCOM file contains a link to a picture file "Mary.jpg" located in a subfolder called 'Media', this picture will not be found unless there really is a subfolder called 'Media' in the same folder as the GEDCOM file, which has a picture file called 'Mary.jpg' in it. Consequently, if you want your media to appear, you would need to copy the media to the equivalent location relative to your exported GEDCOM file. Depending on how your media is stored in your project folder, this might just mean creating a subfolder called 'Media' in the same location as the exported file, and copying media files from your project folder into that.
Instead of using 'Use Existing File Paths for External File Links' you may prefer to use 'Use Full File Paths for External File Links'. The effect of this option is that Family Historian will convert all relative file links to absolute file links in the exported file. If you open a GEDCOM file, after using this option, you should find that all the media still appear correctly. This is because the GEDCOM file now contains links which reference the location of the media files on your PC, and are not relative to the location of the exported file. However, if you send this GEDCOM file, on its own, to someone else on another computer, they will still not be able to see the media because those files aren't on their computer. Of course you could send them the media files separately, but unless they placed these media files on their computer, exactly where Family Historian expected them to be (which would be hard to arrange), they still would not be found.
Yet another option - which will only work if your data is kept in a project and you allow Family Historian to store media in the project folder - is not to export a GEDCOM file at all, but instead to simply give the person a copy of your entire project folder (if you prefer, you could make a copy of the project folder first and then delete extraneous information using the Split Tree Helper tool - accessible from the File menu). Of course if your recipient uses Family Historian, they will be able to open the project and see the media. But even if they use another genealogy program, they can still open the GEDCOM file within the project folder, and depending on the capabilities of their genealogy application, they may be able to load and view the media files in the project folder too. This works because Family Historian stores record data in GEDCOM files, even within its own project folders.
To learn more about how Family Historian stores media, run the Work with External File Links tool (available on the Tools menu), and click its button to understand the information it is giving you, and what you can do with it.