Notes for Upgrading Users

Upgrading from Version 3 or Earlier


If you are upgrading from version 3, or any earlier version, you may be wondering what 'projects' are for and where your old data is. Also - what happened to GEDCOM? Didn't Family Historian used to keep genealogy data in GEDCOM files?

The answer is that yes it did - and it still does. That side of things hasn't changed. But even with version 3 and earlier, a typical Family Historian user often had a large number of other files that were associated in one way or another to each GEDCOM file. These additional files included media files of all kinds, but also chart files and output files - such as website files or family tree CD files - and other files that Family Historian created for you, for one reason or another.

Since version 4, Family Historian has had the capability to manage all these files for you, as well as your GEDCOM data file, in a single project folder on your hard disk. Each project gets its own folder, and all the files relating to that project can be kept in that folder. That has numerous advantages. It makes it much easier to back up and restore all of the data relating to a given GEDCOM file (that is, to a given project). It also makes it much easier to make copies of this data to give to other people. And it makes it easier for the designers of Family Historian, to add more powerful features, while at the same time making the program easier to use than ever.

So what do I need to do now?

Although you don't actually have to (see Frequently Asked Questions below), we strongly recommend that you create a new project now, and import your existing GEDCOM file into that project - if you aren't already using projects. To create a new project, click New Project on the Project Window and follow the instructions. If you have media files linked to your GEDCOM files, we recommend that you let Family Historian copy these files into the new project folder that it will create (again, see Frequently Asked Questions below for more on this). If you have more than one GEDCOM file that you use to store your genealogy research, we recommend that you create one project for each one.

If you can't remember where your GEDCOM file is located on your hard disk - don't worry. When you  click  on the New Project button, a wizard will appear that will take you through the steps of creating your new project. You will be prompted to select the GEDCOM file you wish to import. When you click on the Browse button, it will show you a list of recent GEDCOM files that you have worked on using Family Historian, if there are any. You should be able to simply pick your GEDCOM file from this list.

Frequently Asked Questions

I am upgrading from version 3 (or earlier).  Do I have to import a GEDCOM file into a project before I can view or edit it in Family Historian?

No you don't. You can use Family Historian to create new GEDCOM files, open and edit existing GEDCOM files, save changes, and so on. In fact you can do most of the things you used to be able to do with GEDCOM files. There are however some features which are only supported in the context of a project - such as creating a website, a Family Tree CD or DVD, or a book.

To work with GEDCOM files, see the Gedcom File Tasks submenu on the main program File menu, or the Gedcom File Tasks submenu on the menu that appears when you click on the More Tasks button in the Project Window.

I have my own system for organising media files. If I create a new project and let Family Historian copy my media files into the new project folder, will it just copy them all into one subfolder?

The answer is - it depends on how you organise your media files. Family Historian will handle media files differently depending on where they are located on your hard disk. Any media files that are located in the same folder as the GEDCOM file you are importing, or in a subfolder beneath it, will be copied to the 'Media' subfolder within the new project folder, preserving the original folder structure as much as possible. For example, if the GEDCOM file was in a folder "C:\My family", and you had media files in that folder, they would be copied directly to the new 'Media' folder when you created the new project. If you had other media files in a folder "C:\My family\Pics", a new 'Pics' subfolder would be created within the new 'Media' folder, and those media files would be copied there. Any files which are not in the same folder as the GEDCOM file, or in a subfolder beneath it, would just be copied directly to the new 'media' folder. Family Historian will resolve any name clashes by making minimal name changes, where necessary.

What this means is that if you have your own system for organising your media files, and you want the folder structure to be preserved within the new project folder being created, and if your media files are not already located in the same folder as your old GEDCOM file (or in subfolders beneath it), you could just go ahead with the import and move media files around later; but it would probably be quicker and easier to re-organise the way you store your media files before doing the import, to move the relevant media files into the same folder as (or subfolders beneath) the GEDCOM file. When you move media files around, any GEDCOM file that contains links to them will now have 'broken' links. So before doing anything else, you should open the GEDCOM file that contains these 'broken' links, and repair them using the External File Links tool on the Tools menu. Click the Auto Repair Links button on this tool, to get Family Historian to search for the missing files and repair the links for you.  Alternatively, if you want more control, you can use the tool, to spot and repair broken file links yourself (click the Help button for instructions on how to use it). Remember that you must repair the links before importing the GEDCOM file into a new project, if you want to get the benefit of moving the files in the first place.

Of course, if you don't have any media (pictures, video or sound files etc), or you don't care how Family Historian organises your media files within the new project folder, or if you don't want Family Historian to copy the media files anyway, you don't need to concern yourself with any of this.

How can I check which folders the media files have been copied into, after importing into the new project?

Run  the External File Links tool on the Tools menu.

What happens afterwards, when I add new pictures to the project I have created? How can I control which folder they get put into?

Whenever you add pictures to a project you will be asked if you want to copy the pictures into the project folder. If you opt to do so (which we recommend), Family Historian will let you choose the folder location within the project folder - if that's what you want.  You can just leave it up to Family Historian to copy the files to the default location, which will be the 'Media' subfolder.

Within a project, does Family Historian use 'relative' file links to media in the Project folder (i.e. so that you can copy the folder anywhere and all the links will still work)?

Yes it does.

I have broken links after importing my GEDCOM file into a new project - how could that have happened?

The first and most obvious way that this can happen is if they were broken before you did the import. Family Historian can't copy files if they aren't where they're supposed to be.

You can also get broken links if you copy your original GEDCOM file to a new location, without copying any media files with it, and then try to import from this copy of your GEDCOM file into the new project. This is actually a variant on the same problem. If you open your GEDCOM file in the new location, and click on External File Links on the Tools menu, chances are that you will find that when you copied the GEDCOM file, in the process of doing so you 'broke' some of your old media file links. The solution is simple: don't copy your GEDCOM file and then import from the copy. Do the import directly from the original GEDCOM file where your links were working. There is no reason not to do that. Using a file as part of an import does not modify it in any way.

Do I still need my old GEDCOM file after I have imported it into a new project?

No you don't. We strongly recommend that you make a backup copy of it before you delete it though, just in case.

When I imported my old version 3 GEDCOM file into a new project I got an exception report. Why?

Version 3 had an error in its GEDCOM support which allowed a Source record to have more than one 'Actual Text' field. This is not valid GEDCOM and Family Historian hasn't allowed it since version 4. If you get this report when you import a GEDCOM file, you should save the report and check it carefully.