Understanding Projects

Hints for New Users

If you have just started using Family Historian, then you are probably at the Project Window. If the window you are looking at says “Project Window” in the caption, then that’s what it is.

When Family Historian is first installed, you will see only one project in the Projects list. This is Family Historian Sample Project. You can open and browse the sample project if you wish; but do not use it to store your own family tree information. For that you should create your own project.

If you do browse the sample project, you will need to know how to get back to the Project Window! To do that, simply close the sample project – which you do by clicking Close Project on the File menu. Whenever you close the current project, the Project Window will be re-displayed. You can also view the Project Window at any time, without closing the current project, by clicking on Project Window on the File menu.

To create your own project, click on the New Project button on the Projects Window, and follow the instructions. If you make your project the default project, you will find that the next time you run Family Historian, it will automatically load that project, and effectively skip past the Projects Window. That means that any information you enter will be added to that project. That’s fine. You can use one project to store all the genealogy data that you accumulate. But if you ever need to create any more projects (or to have another look at the sample project) remember that you can always get back to the Project Window by closing the current project, or by clicking Project Window on the File menu.

To open an existing project from the Projects Window, simply double-click on any listed project, or select it and click on the Open Project button.

When you have created your first project, if you need more help, click on Getting Started on the Help menu.

Hints for users upgrading from version 3 or earlier

If you previously used version 3 of Family Historian, or any version earlier than that, you may be wondering what ‘projects’ are for and where your old data is. Also – what happened to GEDCOM? Didn’t Family Historian used to keep genealogy data in GEDCOM files?

The answer is that yes it did – and it still does. That side of things hasn’t changed at all. But even with previous versions, a typical Family Historian user often had a large number of other files that were associated in one way or another to each GEDCOM file. These additional files included multimedia files of all kinds, but also chart files and output files – such as website files or family tree CD files – and other files that Family Historian created for you, for one reason or another.

From version 4 onwards, Family Historian has had the capability to manage all these files for you, as well as your GEDCOM data file, in a single project folder on your hard disk. Each project gets its own folder, and all the files relating to that project can be kept in that folder. That has numerous advantages. It makes it much easier to back up and restore all of the data relating to a given GEDCOM file (that is, to a given project). It also makes it much easier to make copies of this data to give to other people. And it makes it easier for the designers of Family Historian, to add more powerful features, while at the same time making the program easier to use than ever.

So what do I need to do now?

Although you don’t actually have to (see Frequently Asked Questions below), we strongly recommend that you create a new project now, and import your existing GEDCOM file into that project. To do this, click New Project and follow the instructions. If you have multimedia files linked to your GEDCOM files, we recommend that you let Family Historian copy these files into the new project folder that it will create (again, see Frequently Asked Questions below for more on this). If you have more than one GEDCOM file that you use to store your genealogy research, we recommend that you create one project for each one.

If you can’t remember where your GEDCOM file is located on your hard disk – don’t worry. When you click on the New Project button a wizard will appear that will take you through the steps of creating your new project. You will be prompted to select the GEDCOM file you wish to import. When you click on the Browse button, it will show you a list of recent GEDCOM files that you have worked on using Family Historian, if there are any. You should be able to simply pick your GEDCOM file from this list.

 

Frequently Asked Questions About Projects

Do I have to import a GEDCOM file into a project before I can view or edit it in Family Historian?

No you don’t. You can use Family Historian to create new GEDCOM files, open and edit existing GEDCOM files, save changes, and so on. In fact you can do almost everything you used to be able to do with GEDCOM files. There are however a small number of features which are now only supported in the context of a project – such as creating a website, or a Family Tree CD.

To work with GEDCOM files, see the Gedcom File Tasks submenu on the main program File menu, or the Gedcom File Tasks submenu on the menu that appears when you click on the More Tasks button in the Project Window.

 

I have my own system for organising multimedia files. If I create a new project, import my old GEDCOM file, and let Family Historian copy my multimedia files into the new project folder, will it just copy them all into one subfolder?

The answer is – it depends on how you organise your multimedia files. Family Historian will handle multimedia files differently depending on where they are located on your hard disk. Any multimedia files that are located in the same folder as the GEDCOM file you are importing, or in a subfolder beneath it, will be copied to the ‘Media’ subfolder within the new project folder, preserving the original folder structure as much as possible. For example, if the GEDCOM file was in a folder “C:\My family”, and you had multimedia files in that folder, they would be copied directly to the new ‘Media’ folder when you created the new project. If you had other multimedia files in a folder “C:\My family\Pics”, a new ‘Pics’ subfolder would be created within the new ‘Media’ folder, and those multimedia files would be copied there. Any files which are not in the same folder as the GEDCOM file, or in a subfolder beneath it, would just be copied directly to the new ‘media’ folder. Family Historian will resolve any name clashes by making minimal name changes, where necessary.

What this means is that if you have your own system for organising your multimedia files, and you want the folder structure to be preserved within the new project folder being created, and if your multimedia files are not already located in the same folder as your old GEDCOM file (or in subfolders beneath it), you could just go ahead with the import and move multimedia files around later; but it would probably be quicker and easier to re-organise the way you store your multimedia files before doing the import, to move the relevant multimedia files into the same folder as (or subfolders beneath) the GEDCOM file. When you move multimedia files around, any GEDCOM file that contains links to them will now have ‘broken’ links. So before doing anything else, you should open the GEDCOM file that contains these ‘broken’ links, and repair them using the Work with External File Links tool on the Tools menu. Using this tool, you can usually spot and repair all broken file links very quickly and easily. Remember that you must repair the links before importing the GEDCOM file into a new project, if you want to get the benefit of moving the files in the first place.

Of course, if you don’t have any multimedia (pictures, video or sound files etc), or you don’t care how Family Historian organises your multimedia files within the new project folder, or if you don’t want Family Historian to copy the multimedia files anyway, you don’t need to concern yourself with any of this.

How can I check which folders the multimedia files have been copied into after the import into the new project?

Run the Work with External File Links tool on the Tools menu.

What happens afterwards, when I add new pictures to the project I have created? How can I control which folder they get put into?

When you add pictures to a project you will be asked if you want to copy the pictures into the project folder. If you opt to do so (which we recommend), Family Historian will let you choose the folder location within the project folder, if that’s what you want – or you can just leave it up to Family Historian to copy them to the default location, which will be the ‘Media’ subfolder.

Within a project, does Family Historian use ‘relative’ file links to multimedia in the Project folder?

(i.e. so that you can copy the folder anywhere and all the links will still work)?

Yes it does.

I have broken links after importing my GEDCOM file into a new project – how could that have happened?

The first and most obvious way that this can happen is if they were broken before you did the import. Family Historian can’t copy files if they aren’t where they’re supposed to be.

You can also get broken links if you copy your original GEDCOM file to a new location, without copying any multimedia files with it, and then try to import from this copy of your GEDCOM file into the new project. This is actually a variant on the same problem. If you open your GEDCOM file in the new location, and click on Work with External File Links on the Tools menu, chances are that you will find that when you copied the GEDCOM file, in the process of doing so you ‘broke’ some of your old multimedia file links. The solution is simple: don’t copy your GEDCOM file and then import from the copy. Do the import directly from the original GEDCOM file where your links were working. There is no reason not to. Using a file as part of an import does not modify it in any way.

Do I still need my old GEDCOM file after I have imported it into a new project?

No you don’t. We strongly recommend that you make a backup copy of it before you delete it though, just in case.

How can I delete a project I have created?

Simply delete the entire project folder using Windows Explorer. Be clear about what you’re deleting though, and don’t delete more than you need to. If the folder you are deleting includes the Family Historian Sample Project folder too, you’re deleting too much!

How can I rename a project?

Right click on it in the listing in the Project Window and select Project Properties. You can rename it there.

58 queries. 0.753 seconds. Current Time:26-05-17 22:21:44 UTC